【POJ - 3273 】Monthly Expense (二分,最大最小值)

版权声明:欢迎学习我的博客,希望ACM的发展越来越好~ https://blog.csdn.net/qq_41289920/article/details/83155568

题干:

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M 
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

题目大意:

给你一个长度为N的序列,现在需要把他们切割成M个子序列(所以每一份都是连续的),使得每个子序列和均不超过某个值X,输出X的最小值。

换句话说,切成M份,然后每一份都有一个和sum[i],其中最大的一个是maxSum = max(sum[i]),问这个最大值最小是多少?

解题报告:

    刚开始读题以为要加点贪心,后来发现是要切割数组,所以是连续的,不能排序、、、白白WA一发、、

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream> 
#define ll long long
using namespace std;
ll sum,a[100005];
ll n,m;
bool ok(ll lim) {
	int cnt = 0;
	ll cur = 0;
	for(int i = 1; i<=n; i++) {
		if(cur + a[i] <= lim) {
			cur+= a[i];
		}
		else {
			cnt++;
			cur=0;
			i--;
		}
	}
	if(cnt >= m) return 0;
	else return 1;
}
int main()
{

	cin>>n>>m;
	for(int i = 1; i<=n; i++) scanf("%lld",a+i),sum += a[i];
//	sort(a+1,a+n+1);
	ll l = *max_element(a+1,a+n+1),r = sum;
	ll mid = (l+r)/2;
	while(l < r) {
		mid = (l+r)/2;
		if(ok(mid)) r=mid;
		else l=mid+1; 
	}
	printf("%lld\n",l);
	return 0 ;
 } 

猜你喜欢

转载自blog.csdn.net/qq_41289920/article/details/83155568