POJ 3273 Monthly Expense 【二分查找】


Monthly Expense
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14158   Accepted: 5697

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers:  N and  M 
Lines 2.. N+1: Line  i+1 contains the number of dollars Farmer John spends on the  ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source



题意: 给n个数分成m个区间,区间内的数字必须与原来的数组顺序一致,个个区间的数字加起来的总和有一个区间是最大的,怎么划分才能使这个最大值是最小的;

思路: 左值 是数组中最大的那个值,右值是所有数组的总和,所要求的数就在这两个值得中间,通过二分查找来求出答案;确定二分的左右值,还有一个关键的就是二分查找过程中,是 right = mid 还是 left = mid; 要分成 m个区间,实际就是在数组中切 m - 1 刀,我们从第一个开始累加,直到这个总数大于 mid ,则总数归零,继续累加下一个区间,每完成一个区间的累加就让 cnt 计数一次,如果到最后,cnt(就是切的刀数) > m - 1 则说明这个mid 小了,反之则大了,通过这个来判断 mid 是赋值给right 还是left ,下面给出代码:


#include<iostream>
#include<string>
#include<map>
#include<cstdlib>
#include<queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 1e6+10;

long long a[maxn];
int n,m;

bool check(long long mid_) {
    long long sum_ = 0,cnt;
    for(int i = 0 ; i < n; ++i) {
        sum_+=a[i];
        if(sum_ > mid_) {
            sum_ = 0;
            i--;
           cnt++;
        }
    }
    //判定刀数
    if(cnt  > m - 1) return false;
    else return true;
}
int main(void)
{
    while(scanf("%d%d",&n,&m)!=EOF) {
            long long sum = 0,num_max = 0;
            for(int i = 0 ; i < n ; ++i) {
                scanf("%lld",&a[i]);
               if(num_max < a[i]) num_max = a[i];
               sum+=a[i];
            }
          long long le = num_max,ri = sum,mid;
          while(le < ri) {
                mid = (le + ri)/2;
                if(check(mid)) ri = mid - 1;
                else le = mid + 1;
          }
        printf("%d\n",le);
    }
    return 0;
}














猜你喜欢

转载自blog.csdn.net/godleaf/article/details/80588695