Monthly Expense POJ - 3273 (最大值最小化)(二分答案)

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
 
题目意思:共n个月,给出每个月的开销.将n个月划分成m个时间段,求m个时间段中开销最大的时间段的最小开销值。
 
思路:二分(最大值最小化)
 
代码:
#include <iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <string>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
//#include <unordered_map>
#define Fbo friend bool operator < (node a, node b)
#define mem(a, b) memset(a, b, sizeof(a))
#define FOR(a, b, c) for(int a = b; a <= c; a++)
#define RFOR(a,b, c) for(int a = b; a >= c; a--)
#define sc(a) scanf("%lld",&a)
#define off ios::sync_with_stdio(0)
bool check1(int a) { return (a & (a - 1)) == 0 ? true : false; }

using namespace std;
typedef pair<int, int> pii;
typedef long long ll;
const int INF = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const int Maxn = 2e5 + 5;
const double pi = acos(-1.0);
const double eps = 1e-8;

ll a[Maxn];
ll n, m, l, r, mid;

int solve() {
    ll sum = 0, ans = 1;
    FOR(i, 1, n) {
        sum += a[i];
        if (sum >= mid) {
            if (i != n)ans++;
            if (sum == mid) sum = 0;
            else sum = a[i];
        }
    }
    if (ans > m)
        return 0; //需要把每个周期用的钱增加
    return 1;
}

int main() {
    sc(n), sc(m);
    FOR(i, 1, n) {
        sc(a[i]);
        l = max(l, a[i]);
        r += a[i];
    }
    while (l < r) {
        mid = (l + r) / 2;
        if (!solve()) {
            l = mid + 1;
        }
        else r = mid - 1;
    }
    printf("%lld\n", l);
}

猜你喜欢

转载自www.cnblogs.com/AlexLINS/p/12643937.html