poj3273—Monthly Expense(二分)

Monthly Expense

http://poj.org/problem?id=3273

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 36945   Accepted: 13718

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day

Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.

Sample Input

7 5
100
400
300
100
500
101
400

Sample Output

500

Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.

Source

USACO 2007 March Silver

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<cmath>
const int maxn=100000+100;
using namespace std;
 int n,k;
 int a[maxn];
int check(double m){
    double HH=m;
    int cnt=0;
    m=0;
    for(int i=1;i<=n;i++){
        if(a[i]<=m)
            m-=a[i];
        else{
            cnt++;
            m=HH;
            if(a[i]>m)
                return 0;
            else
                m-=a[i];
        }
    }
    if(cnt<=k)
        return 1;
    else
        return 0;
}
int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++){
        scanf("%d",&a[i]);
    }
    double L=0;
    double R=100001;
    double mid;
    int lala=100;
    while(lala--){
        mid=(L+R)/2;
        if(check(mid)){///取大了
            R=mid;
        }
        else
            L=mid;
    }
    int xpp=floor(mid);
  ///  cout<<L<<"  "<<R<<endl;
    printf("%d\n",xpp);
    return 0;
}
发布了565 篇原创文章 · 获赞 110 · 访问量 11万+

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/87005837