2016 ACM/ICPC大连区域赛 E—Aninteresting game【树状数组】

题目链接:http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1005&cid=736

Aninteresting game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 120    Accepted Submission(s): 20

 

Problem Description

Let’s play a game.We add numbers 1,2...n in increasing order from 1 and put them into some sets.
When we add i,we must create a new set, and put iinto it.And meanwhile we have to bring [i-lowbit(i)+1,i-1] from their original sets, and put them into the new set,too.When we put one integer into a set,it costs us one unit physical strength. But bringing integer from old set does not cost any physical strength.
After we add 1,2...n,we have q queries now.There are two different kinds of query:
1 L R:query the cost of strength after we add all of [L,R](1≤L≤R≤n)
2 x:query the units of strength we cost for putting x(1≤x≤n) into some sets.

Input

There are several cases,process till end of the input.
For each case,the first line contains two integers n and q.Then q lines follow.Each line contains one query.The form of query has been shown above.
n≤10^18,q≤10^5

Output

For each query, please output one line containing your answer for this query

Sample Input

10 2

1 8 9

扫描二维码关注公众号,回复: 3548621 查看本文章

2 6

Sample Output

9

2

Hint

lowbit(i) =i&(-i).It means the size of the lowest nonzero bits in binary of i. For example, 610=1102, lowbit(6) =102= 210 When we add 8,we should bring [1,7] and 8 into new set. When we add 9,we should bring [9,8] (empty) and 9 into new set. So the first answer is 8+1=9. When we add 6 and 8,we should put 6 into new sets. So the second answer is 2.

参考于大佬的博客:https://blog.csdn.net/LSD20164388/article/details/82932560

题意:

每次查询有两种操作

op1:求加入L~R的数时所消耗的单元

op2:求将x加入集合或移动到其它集合所消耗的单元(即由x引起消耗的单元)

思路:op1:每次加入一个数i 那么同时会移动[i-lowbit(i)+1 , i-1] ,总的消耗是i-(i-lowbit(i)+1) +1=lowbit(i) 所以每次加入一个数对应的消耗是2的幂次,1..n的消耗是n包含的2的幂次与个数的乘积ans+=(n/(1<<i)-n/(1<<(i+1)))*(1<<i),那么求L~R求差就行。

解释一下,n/(1<<i)-n/(1<<(i+1))表示长为2^i的消耗的数的个数,例如:n=10 , 包含长为2的数是2,6,10 为什么4,8不是,因为它们虽然是2的倍数,但更是4的倍数,包含更长的区间了,所以这部分要减去。

op2:由树状数组可知 [i-lowbit(i)+1 , i-1] 是以i为根节点对应的区间,如果假如的数能够移动i ,那么这个数对应的孩子区间一定包含i ,所以从x向上一直找父节点即可。

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f3f3f3f3fLL
using namespace std;
const int maxn=100010;
const ll mo=1e9+7;
ll n,m,k,q;
ll ans,tmp,cnt;
ll lb(ll x){return x&(-x);}
ll query(ll x)
{
    ll ans=0;
    while(x<=n)
    {
        ans++;
        x+=lb(x);
    }
    return ans;
}
ll cal(ll x)
{
    ll tmp=1,ans=0;
    while(tmp<=x)
    {
        ans+=((x/tmp)-(x/(tmp<<1)))*tmp;
        tmp<<=1;
    }
    return ans;
}
int main()
{
    while(scanf("%lld%lld",&n,&q)!=EOF)
    {
        int op;
        ll x,y;
        while(q--)
        {
            scanf("%d",&op);
            if(op==1)
            {
                scanf("%lld%lld",&x,&y);
                printf("%lld\n",cal(y)-cal(x-1));
            }
            else
            {
                scanf("%lld",&x);
                printf("%lld\n",query(x));
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/82934063
今日推荐