1043 输出PATest

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/piaoliangjinjin/article/details/81903779

给定一个长度不超过 10​4​​ 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 10​4​​ 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

分析:

// B43.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <string>
using namespace std;


int main()
{
	string s;
	cin >> s;
	int length = s.length();
	int a[6] = { 0 };
	for (int  i = 0; i < length; i++)
	{
		if (s[i] == 'P')
		{
			a[0] ++;
		}
		else if (s[i] == 'A')
		{
			a[1] ++;
		}
		else if (s[i] == 'T')
		{
			a[2] ++;
		}
		else if (s[i] == 'e')
		{
			a[3] ++;
		}
		else if (s[i] == 's')
		{
			a[4] ++;
		}
		else if (s[i] == 't')
		{
			a[5] ++;
		}
	}
	for (int i = 0; i < length; i++)
	{
		if (a[0] != 0)
		{
			cout << "P";
			a[0]--;
		}
		if (a[1] != 0)
		{
			cout << "A";
			a[1]--;
		}
		if (a[2] != 0)
		{
			cout << "T";
			a[2]--;
		}
		if (a[3] != 0)
		{
			cout << "e";
			a[3]--;
		}
		if (a[4] != 0)
		{
			cout << "s";
			a[4]--;
		}
		if (a[5] != 0)
		{
			cout << "t";
			a[5]--;
		}
	}
	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/piaoliangjinjin/article/details/81903779