PAT - 乙级 1043 输出PATest

1043. 输出PATest(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee

#include<cstdio>
#include<cstring>
using namespace std;

int main(){
	char arr[10005], ans[6];
	gets(arr);
	memset(ans, 0, sizeof(ans));
	int n = strlen(arr);
	for(int i = 0; i < n; i++){
		if(arr[i] == 'P') ans[0]++;
		else if(arr[i] == 'A') ans[1]++; 
		else if(arr[i] == 'T') ans[2]++;
		else if(arr[i] == 'e') ans[3]++;
		else if(arr[i] == 's') ans[4]++;
		else if(arr[i] == 't') ans[5]++;
	}
	int flag = 0;
	while(!flag){
		for(int i = 0 ; i < 6; i++){
			if(ans[i] != 0){
				if(i == 0) printf("P");
				else if(i == 1) printf("A");
				else if(i == 2) printf("T");
				else if(i == 3) printf("e");
				else if(i == 4) printf("s");
				else if(i == 5) printf("t");
				ans[i]--;
			}	
		}
		for(int i = 0 ; i < 6; i++){
			if(ans[i] != 0) break;
			else if(i == 5)flag = 1;
		}
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/yf224/article/details/80200814