B1043 输出PATest (20 分)

给定一个长度不超过 10​^4​​ 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过 10​^4​​ 的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee

注意:

  1.  开一个数组 hashTable[6] 用来记录 PATest这六个字符出现的个数,再读入字符串时,可以直接统计这个数组
  2. 为了不重复判断 str[i] 是否是 PATest中一个,开一个char 型数组 dict,来存放这6个字符,这样在遍历数组dict 时,可以直接对应到hashTable 的下标。
  3. 读入字符串时,用sum来记录这六个字符的个数,由此来判断何时停止输出
#include <cstdio>
#include <cstring>
const int maxn = 10010;
char str[maxn], dict[6] = {'P', 'A', 'T', 'e', 's', 't'};
int hashTable[6] = {0};
int main(){
  scanf("%s", str);
  int len = strlen(str),sum = 0;
  for(int i = 0; i < len; i++){
    for(int j = 0; j < 6; j++){
      if(str[i] == dict[j]){
        hashTable[j]++;
        sum++;
      }
    }
  }
  while(sum > 0){
    for(int i = 0; i < 6; i++){
      if(hashTable[i] > 0){
        printf("%c", dict[i]);
        hashTable[i]--;
        sum--;
      }
    }
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86609410
今日推荐