PAT-1008 数组元素循环右移问题

版权声明:一只努力变强的编程汪,欢迎交流! https://blog.csdn.net/qq_42020563/article/details/82958732

1008 数组元素循环右移问题 (20 分)

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A​0​​A​1​​⋯A​N−1​​)变换为(A​N−M​​⋯A​N−1​​A​0​​A​1​​⋯A​N−M−1​​)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:

每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。

输出格式:

在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4
#include<iostream>
using namespace std;
int main()
{
  int n,m,a[100]={0};
  cin>>n>>m;
  m%=n;//注意有可能m>n的情况下,要取余数
  for(int i=0;i<n;i++)
  {
    cin>>a[i];
  }
  if(m==0)//分为2种情况,m=0和不等于0
  {
  for(int i=0;i<n-m-1;i++)
  {
    cout<<a[i]<<" ";
  }
  cout<<a[n-m-1];
  return 0;
  }
  else
  {
  for(int i=n-m;i<=n-1;i++)
  {
    cout<<a[i]<<" ";
  }
  for(int i=0;i<n-m-1;i++)
  {
    cout<<a[i]<<" ";
  }
  cout<<a[n-m-1];
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42020563/article/details/82958732
今日推荐