PAT 1008 数组元素循环右移问题

https://pintia.cn/problem-sets/994805260223102976/problems/994805316250615808

一个数组A中存有N(N&gt0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A~0~ A~1~……A~N-1~)变换为(A~N-M~ …… A~N-1~ A~0~ A~1~……A~N-M-1~)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:每个输入包含一个测试用例,第1行输入N ( 1<=N<=100)、M(M>=0);第2行输入N个整数,之间用空格分隔。

输出格式:在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4

代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;
int a[maxn],b[maxn];

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    m=m%n;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    for(int i=n-m+1;i<=n;i++)
    {
        //for(int j=i-n+m;j<=m;j++)
            b[i-n+m]=a[i];
    }
    for(int i=1;i<=n-m;i++)
    {
        //for(int j=m+i;j<=n;j++)
            b[i+m]=a[i];
    }
    for(int i=1;i<=n;i++)
    {
        if(i!=n)
        printf("%d ",b[i]);
        else
            printf("%d",b[i]);
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9286292.html
今日推荐