poj 3620Avoid The Lakes(求最大联通块)

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4

Source

USACO 2007 November Bronze

dfs

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int map[105][105]={0};
int dir[4][2]={-1,0,1,0,0,-1,0,1};
int sum=0,ans=0,n,m,k;
void dfs(int a,int b)
{
    int a1,b1;
    ans++;
    map[a][b]=0;
    for(int i=0;i<4;i++)
    {
        a1=a+dir[i][0];
        b1=b+dir[i][1];
        if(a1>=1&&a1<=n&&b1>=1&&b1<=m&&map[a1][b1])
        dfs(a1,b1);

    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&k);
    for(int i=1;i<=k;i++)

    {int x,y;
        scanf("%d%d",&x,&y);
        map[x][y]=1;
    }
    for(int i=1;i<=n;i++)
    for(int j=1;j<=m;j++)
    {
        if(map[i][j])
        {ans=0;

        dfs(i,j);
        if(ans>sum)
        sum=ans;}
    }
    printf("%d\n",sum);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/82933411