Shift only

题目描述

There are N positive integers written on a blackboard: A1,…,AN.
Snuke can perform the following operation when all integers on the blackboard are even:
Replace each integer X on the blackboard by X divided by 2.
Find the maximum possible number of operations that Snuke can perform.

Constraints
1≤N≤200
1≤Ai≤109

输入

Input is given from Standard Input in the following format:
N
A1 A2 ... AN

输出

Print the maximum possible number of operations that Snuke can perform.

样例输入

3
8 12 40

样例输出

2

提示

Initially, [8,12,40] are written on the blackboard. Since all those integers are even, Snuke can perform the operation.
After the operation is performed once, [4,6,20] are written on the blackboard. Since all those integers are again even, he can perform the operation.
After the operation is performed twice, [2,3,10] are written on the blackboard. Now, there is an odd number 3 on the blackboard, so he cannot perform the operation any more.
Thus, Snuke can perform the operation at most twice.

题目描述
黑板上有N个正整数A1…AN。
当黑板上的所有整数都是偶数时,Snuke可以执行以下操作:
将黑板上的每个整数X替换为X / 2。
查找Snuke可以执行的操作的最大可能数量。
约束
1≤N≤200
1≤Ai≤109
输入
输入来自以下格式的标准输入:
N
A1 A2……一个
输出
打印Snuke可以执行的最大操作数。
样例输入
3
8 12 40
样例输出
2

#include <iostream>
#define inf 0x3f3f3f
using namespace std;
int a[210],n;
int panduan()
{
    int i;
    for(i=0;i<n;i++)
    {
        if(a[i]%2!=0)
            return 0;
    }
    return 1;
}
int main()
{
    int c=0;
    int i,j;
    cin>>n;
    for(i=0;i<n;i++)
        cin>>a[i];
    while(panduan()==1)
    {
        c++;
        for(i=0;i<n;i++)
            a[i]/=2;
    }
    cout<<c<<endl;
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/wangws_sb/article/details/81561507
今日推荐