UPC 问题 L: Shift only

问题 L: Shift only
时间限制: 1 Sec 内存限制: 128 MB
提交: 286 解决: 223
[提交] [状态] [讨论版] [命题人:admin]
题目描述

There are N positive integers written on a blackboard: A1,…,AN.
Snuke can perform the following operation when all integers on the blackboard are even:
Replace each integer X on the blackboard by X divided by 2.
Find the maximum possible number of operations that Snuke can perform.

Constraints
1≤N≤200
1≤Ai≤109

输入

Input is given from Standard Input in the following format:
N
A1 A2 … AN

输出

Print the maximum possible number of operations that Snuke can perform.

样例输入

3
8 12 40

样例输出

2

#include<bits/stdc++.h>
using namespace std;
int del(int a[],int n,int flag)
{
    for(int i=0;i<n;i++){
        a[i]=a[i]/2;
        if(a[i]%2!=0)
            flag=0;
    }
    return flag;
}
int main()
{
    int n;cin>>n;
    int num[n];
    int flag=1;
    int cnt=0;
    for(int i=0;i<n;i++)
    {
        cin>>num[i];
        if(num[i]%2!=0)
            flag=0;
    }
    if(flag==0)
        cout<<"0"<<endl;
    else
    {
        while(flag==1){
            flag=del(num,n,flag);
            cnt++;
        }
        cout<<cnt<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81568533
UPC