Chip Factory(01字典树求异或最大值)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sxh759151483/article/details/82940434

题目描述

John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip
produced this day has a serial number si.
At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:

which i, j, k are three different integers between 1 and n. And is symbol of bitwise XOR.
Can you help John calculate the checksum number of today?

输入

The first line of input contains an integer T indicating the total number of test cases.
The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1 , s2 ,..., sn , separated with single space, indicating serial number of each chip.

  • 1≤T≤1000
  • 3≤n≤1000
  • 0≤s i≤109
  • There are at most 10 testcases with n > 100

输出

For each test case, please output an integer indicating the checksum number in a line.

样例输入

2
3
1 2 3
3
100 200 300

样例输出

6
400

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e3+5;
int ch[32 * maxn][2], val[32 * maxn], sz;

void init() {
	ch[0][0] = ch[0][1] = 0;
	memset(val, 0, sizeof(val));
	sz = 1;
}

void _insert(ll a) {
	int u = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a >> i) & 1);
		if (!ch[u][c]) {
			ch[sz][0] = ch[sz][1] = 0;
			ch[u][c] = sz++;
		}
		u = ch[u][c];
		val[u]++;
	}
}

void _delete(ll a) {
	int u = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a>>i)&1);
		u = ch[u][c];
		val[u]--;
	}
}
ll query(ll a) {
	int u = 0;
	ll ans = 0;
	for (int i = 32; i >= 0; i--) {
		int c = ((a>>i)&1);
		if (c == 1) {
			if (ch[u][0] && val[ch[u][0]]) {
				ans += 1ll<<i;
				u = ch[u][0];
			} else {
				u = ch[u][1];
			}
		} else {
			if (ch[u][1] && val[ch[u][1]]) {
				ans += 1ll<<i;
				u = ch[u][1];
			} else {
				u = ch[u][0];
			}
		}
	}
	return ans;
}
ll a[1005];
int main() {
	int T, n;
	scanf("%d", &T);
	while (T--) {
		init();
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%lld", &a[i]);
		sort(a, a + n);
		for (int i = 0; i < n; i++)
			_insert(a[i]);
		ll maxx = 0;
		for (int i = 0; i < n; i++) {
			_delete(a[i]);
			for (int j = i + 1; j < n; j++) {
				_delete(a[j]);
				ll ans = query(a[i] + a[j]);
				maxx = max(maxx, ans);
				_insert(a[j]);
			}
			_insert(a[i]);
		}
		printf("%lld\n", maxx);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sxh759151483/article/details/82940434