PAT乙1054求平均值 题目描述 关于输出格式 看清楚 老实复制每一个为上

1054 求平均值 (20)(20 分)
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-10001000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例17
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例22
aaa -9999
输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
  • 注意K=1时 输出是number不是numbers ! 每次都想当然觉得看到的是那样;
  • ‘-’ 只可能出现在第一位
  • ‘.’只能出现一次
  • 数a属于[-1000,1000]
#include<iostream>
#include<cstdio>
using namespace std;
int n,K=0;
string t;
double a,c,res=0;
bool point,wrong;
int Minus,num;
int main()
{
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        cin>>t;
        //judge
        int l=t.length();
        a=0;c=1;
        point=0;Minus=1;wrong=0;num=0;
        for(int j=0;j<l;j++)
        {
            if(t[j]>='0'&&t[j]<='9')
            {
                if(!point)
                a=a*10+(t[j]-'0');
                else
                {
                    if(num==2)
                    {
                        wrong =1;break;
                    }
                    num++;
                    c*=0.1;
                    a=a+c*(t[j]-'0');
                }
            }
            else if(t[j]=='-'&&j==0)
            {
                Minus=-1;
            }
            else if(t[j]=='+'&&j==0)
            {
                Minus=1;
            }
            else if(t[j]=='.'&&!point)
            {
                point=1;
            }
            else
            {
                wrong=1;
                break;
            }
        }
        if(a<-1000||a>1000)wrong=1;
        if(!wrong)
        {
            res+=(Minus*a);
            K++;
        }
        else
        {
            cout<<"ERROR: "<<t<<" is not a legal number"<<endl;
        }
    }
    if(K==1)printf("The average of 1 number is %.2f\n",res);///////
    else if(K)printf("The average of %d numbers is %.2f\n",K,res/K);
    else printf("The average of 0 numbers is Undefined\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40367307/article/details/81297902
今日推荐