Black And White HDU - 5113 (dfs+剪枝)

In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color. 
— Wikipedia, the free encyclopedia 

In this problem, you have to solve the 4-color problem. Hey, I’m just joking. 

You are asked to solve a similar problem: 

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells. 

Matt hopes you can tell him a possible coloring.

Input

The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases. 

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ). 

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used. 

It’s guaranteed that c 1 + c 2 + · · · + c K= N × M . 

Output

For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells. 

If there are multiple solutions, output any of them.

Sample Input

4
1 5 2
4 1
3 3 4
1 2 2 4
2 3 3
2 2 2
3 2 3
2 2 2

Sample Output

Case #1:
NO
Case #2:
YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

题意:给出一个n*m的方阵,给其填上k种颜色,每种颜色ai个。相同的颜色不允许相邻,问是否存在某种排列方式,如不存在则输出NO,如果存在就输出YES,并将排列的方式输出。

思路:数据规模很小,很容易想到爆搜的方式。但是实际上却也不够小,所哟还需要一些灵性的剪枝。这里选择的是当某种颜色的需要填充的数量大于总共需要填充的颜色的数量+1的一半时,则退出搜索。可以想到所有相邻的格子至少需要其数量-1个的其他颜色格子分开才是可行的。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int vis[10][10];
int cnt[30];
int k;
int n,m;
int mov[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool ans;
bool ex_check(int xx,int yy,int C){
	for(int i=0;i<4;i++){
		int x=xx+mov[i][0];
		int y=yy+mov[i][1];
		if(x>=1&&x<=n&&y>=1&&y<=m&&vis[x][y]==C){
			return false;
		}
	}
	return true;
}
bool check(int x,int y,int C){
	if(x>=1&&x<=n&&y>=1&&y<=m&&vis[x][y]==-1)
	{
		if(ex_check(x,y,C)){
			return true;
		}
	}
	return false;
}
void  dfs(int x,int y,int dep)
{
	
	if(dep==n*m+1) ans=true;
	for(int i=1;i<=k;i++){
		if(2*cnt[i]>(n*m+1-dep+1)) {
			return ;
		}
	}
	if(ans) return ;
	for(int i=1;i<=k;i++){
		if(cnt[i]){
			if(check(x,y,i)){
				cnt[i]--;
				vis[x][y]=i;
				for(int j=0;j<4;j++){
					int xx=x+mov[j][0];
					int yy=y+mov[j][1];
					dfs(xx,yy,dep+1);
					if(ans) return;
				}
				cnt[i]++;
				vis[x][y]=-1;
			}
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	int tot=0;
	while(t--){
		memset(vis,-1,sizeof(vis));
		ans=false;
		scanf("%d%d%d",&n,&m,&k);
		for(int i=1;i<=k;i++) scanf("%d",&cnt[i]);
		dfs(1,1,1);
		printf("Case #%d:\n",++tot);
		if(!ans) printf("NO\n");
		else {
			printf("YES\n");
			for(int i=1;i<=n;i++){
				for(int j=1;j<=m;j++){
					printf("%d",vis[i][j]);
					if(j!=m) printf(" ");
					else if(!(!t&&i==n))printf("\n");
				}
			}
		}
	}
}

猜你喜欢

转载自blog.csdn.net/baiyifeifei/article/details/82860100