hdu 5113 Black And White(剪枝)

Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1).

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
 
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
 
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
#include <cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;


const int maxn=30;
struct node{
    int val,id;
}val[maxn];
int ans[6][6];
int n,m,k,flag;

int tmp[maxn];

int cc(int a,int b){
    return a>b;
}

void dfs(int x,int y){
    if(y>m){
        x++,y=1;
    }
    if(x>n){
        flag=1;
        return;
    }
    for(int i=1;i<=k;i++){
        int id=val[i].id;
        if(!val[i].val)continue;
        if(y>1&&ans[x][y-1]==id)continue;
        if(x>1&&ans[x-1][y]==id)continue;
        for(int j=1;j<=k;j++)
            tmp[j]=val[j].val;
        sort(tmp+1,tmp+k+1,cc);
        if(tmp[2]==0&&tmp[1]!=1)continue;
        if(tmp[3]==0&&tmp[2]&&tmp[1]>2*tmp[2])continue;
        val[i].val--;
        ans[x][y]=id;
        dfs(x,y+1);
        if(flag)return;
        val[i].val++;
    }
}

int cmp(node a,node b){
    return a.val>b.val;
}
/*
这个剪枝是真的骚,一开始就给剪了
我还在中间判断,如果上来就大于一半的话,我们就可以直接放弃了
其实想想也是这样
*/

int main()
{
    int T,kase=1;
    scanf("%d",&T);
    while(T--){
        flag=0;
        scanf("%d %d %d",&n,&m,&k);
        for(int i=1;i<=k;i++)scanf("%d",&val[i].val),val[i].id=i;
        sort(val+1,val+k+1,cmp);
        printf("Case #%d:\n",kase++);
       
        if(val[1].val>(n*m+1)/2){
            printf("NO\n");
            continue;
        }
        
        dfs(1,1);
        if(!flag)
            printf("NO\n");
        else{
            printf("YES\n");
            for(int i=1;i<=n;i++){
                for(int j=1;j<=m;j++){
                  if(j==1)printf("%d",ans[i][j]);
                  else printf(" %d",ans[i][j]);
                }
                printf("\n");
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/80286745