HDU 5113 Black And White

Black And White

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 5447    Accepted Submission(s): 1495
Special Judge


Problem Description
In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color.
— Wikipedia, the free encyclopedia

In this problem, you have to solve the 4-color problem. Hey, I’m just joking.

You are asked to solve a similar problem:

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells.

Matt hopes you can tell him a possible coloring.
 

Input
The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases.

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ).

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used.

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M .
 

Output
For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells.

If there are multiple solutions, output any of them.
 

Sample Input
 
  
4 1 5 2 4 1 3 3 4 1 2 2 4 2 3 3 2 2 2 3 2 3 2 2 2
 

Sample Output
 
  
Case #1: NO Case #2: YES 4 3 4 2 1 2 4 3 4 Case #3: YES 1 2 3 2 3 1 Case #4: YES 1 2 2 3 3 1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6275  6274  6273  6272  6271 

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <queue>
#include <stack>
using namespace std;

const int N = 10;
int mp[N][N];
int sum[N*N];
int n, m, k;
int flag;

void output()
{
    for(int i = 0 ; i < n; i++)
    {
        for(int j = 0; j < m; j++)
        {
            if(j!=0) printf(" ");
            printf("%d", mp[i][j]);
        }
        printf("\n");
    }
    return ;
}

bool isable(int x, int y)
{
    if(x < 0 || x >= n || y < 0 || y >= m) return 0;
    else return 1;
}

bool check(int x, int y, int k)
{
    for(int i = 0; i < 2; i++)
    {
        int bx, by;
        if(i == 0)
        {
            bx = x -1;
            by = y;
        }
        else
        {
            bx = x;
            by = y - 1;
        }
        
        if(!isable(bx, by)) continue;
        if(mp[bx][by] == k) return 0;
    }
    
    return 1;
}

void dfs(int x, int y)
{
    //剪枝
    int cou = x*m + y; 
    for(int i = 1; i <= k; i++)
    {
        if((n*m - cou +1)/2 < sum[i]) 
        return ;
    }
    
    if(x == n) 
    {
        flag = 1;
        return ;
    }
    for(int i = 1; i <= k; i++)
    {
        if(sum[i] <= 0) continue;
        if(check(x, y, i) == 0) continue; 
        sum[i]--;
        mp[x][y] = i;
        if(y < m-1)
            dfs(x, y+1);
        else 
            dfs(x+1, 0);
        if(flag) return ;
        sum[i]++;
    }
    return ;
}

int main()
{
    int t;
    scanf("%d", &t);
    for(int cnt = 1; cnt <= t; cnt++)
    {
        scanf("%d %d %d", &n, &m, &k);
        for(int i = 1; i <= k; i++)
        {
            scanf("%d", &sum[i]);
        }
        
        printf("Case #%d:\n", cnt);
        flag = 0;
        dfs(0, 0);
        if(flag != 1) printf("NO\n");
        else 
        {
            printf("YES\n");
            output();
        }
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/yinghui_yht/article/details/80297537