1094 The Largest Generation(BFS,DFS)

1094 The Largest Generation (25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题目大意

家谱图通常是由多个度的树组成,处在同一层的节点属于同一代,我们需要找出最大人口的那一代。

分析

本次考察树的遍历,深度优先遍历和广度优先遍历(BFS,DFS),在遍历每一个节点时,统计当前时刻这个节点所在的层的人口总数,并且时时更新当前最大层和最大层的人口总数

#include<iostream>
#include <vector>
using namespace std;
vector<vector<int> > v;
vector<int> depth_total_people;
int max_gener=0,index=0;
void dfs(int u,int d){
	depth_total_people[d]++;
	if(max_gener<depth_total_people[d]){
		max_gener=depth_total_people[d];
		index=d;
	}
	for(int i=0;i<v[u].size();i++) dfs(v[u][i],d+1);
}
int main() {
	int n,m;
	cin>>n>>m;
	v.resize(n+1);
	depth_total_people.resize(n+1);
	for(int i=0;i<m;i++){
		int id,k;
		cin>>id>>k;
		v[id].resize(k);
		for(int j=0;j<k;j++) cin>>v[id][j];
	}
	dfs(1,1);
	cout<<max_gener<<" "<<index;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/82913208