PAT 甲级 1094 The Largest Generation(bfs)

1094 The Largest Generation(25 分)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

Analysis:

1. use vector to record the tree.

2. bfs and record the level of each node according to its parent

3. count the node of each level an find the largest

C++:

#include<stdio.h>
#include<iostream>
#include<string>
#include<vector>
#include<map>
#include<queue>
#include<set>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
vector<int>v[100]; 
queue<int>q;
int level[100];
int main()
{
	//freopen("1094 The Largest Generation.txt","r",stdin);
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;i++){
		int num,k,child;
		cin>>num>>k;
		while(k--){
			cin>>child;
			v[num].push_back(child);
		}
	}
	q.push(1);
	level[1]=1;
	while(!q.empty()){
		int num=q.front();
		int l=level[num];
		q.pop();
		for(int i=0;i<v[num].size();i++){
			q.push(v[num][i]);
			level[v[num][i]]=l+1;
		}
	}
	int count1[100]={0},maxl=0,j;
	for(int i=1;i<=n;i++)
		count1[level[i]]++;
	for(int i=1;i<100;i++){
		if(maxl<count1[i]){
			maxl=count1[i];
			j=i;
		}		 
	}
	cout<<maxl<<" "<<j;	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/zpjlkjxy/article/details/82318445