1094 The Largest Generation (25 分)(树的遍历,BFS,DFS)

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13

21 1 23

01 4 03 02 04 05

03 3 06 07 08

06 2 12 13

13 1 21

08 2 15 16

02 2 09 10

11 2 19 20

17 1 22

05 1 11

07 1 14

09 1 17

10 1 18

Sample Output:

9 4

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
#include <unordered_set>
using namespace std;
vector<int> v[100];
int book[100];
void dfs(int index,int level){
    book[level]++;
    for(int i=0;i<v[index].size();i++)
        dfs(v[index][i],level+1);
}
int main() {
    int n,m,a,k,c;
    cin>>n>>m;
    for(int i=0;i<m;i++){
        cin>>a>>k;
        for(int j=0;j<k;j++){
            cin>>c;
            v[a].push_back(c);
        }
    }
    dfs(1,1);
    int maxnum=0,maxlevel=1;
    for(int i = 1; i < 100; i++) {
        if(book[i] > maxnum) {
            maxnum = book[i];
            maxlevel = i;
        }
    }
    cout<<maxnum<<" "<<maxlevel;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42068614/article/details/87877292