POJ 2248 Addition Chains【迭代加深搜索】

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_37867156/article/details/82695738

Description

An addition chain for n is an integer sequence with the following four properties: 

  • a0 = 1 
  • am = n 
  • a0 < a1 < a2 < ... < am-1 < am 
  • For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj


You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable. 
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank. 
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space. 

Sample Input

5
7
12
15
77
0

Sample Output

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77

题解:P104。

#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
#include <iostream>
#include <cstring>
#define maxx 200005
using namespace std;
int ans[15];
int n;
int dfs(int cur, int limit) {
    if(cur > limit) {
        if(ans[limit] == n) return 1;
        return 0;
    }
    int vis[105];
    memset(vis,0,sizeof(vis));
    for(int i = cur-1 ; i >= 0; i--)
        for(int j = i ; j >= 0; j--) {
            int temp = ans[i] + ans[j];
            if(temp <= n && !vis[temp]) {
                if(temp <= ans[cur-1]) return 0;
                vis[temp] = 1;
                ans[cur] = temp;
                if(dfs(cur+1, limit)) return 1;
            }
        }
    return 0;
}
int main()
{
    std::ios::sync_with_stdio(false);
    ans[0]=1;
    ans[1]=2;
    while(cin >> n && n) {
        if(n==1) {
            cout<<"1"<<endl;
            continue;
        }
        if(n == 2) {
            cout<<"1 2"<<endl;
            continue;
        }
        for(int i = 2; i <= 11; i++) {
            if(dfs(2,i)){
                for(int j = 0; j < i; j++)
                    cout << ans[j] << " ";
                cout << ans[i] << endl;
                break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37867156/article/details/82695738