D - Constructing Roads POJ - 2421

D - Constructing Roads

POJ - 2421

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意:n个村庄,每个村庄之间有距离,问连通所有村庄最少要修路的长度是多少,同时有些村庄之间的路已经修了。

题解:把已修路的村庄之间的距离改为0,然后之间prim求最小生成树。

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1010;
const int inf = 0x3f3f3f3f;
int g[maxn][maxn],d[maxn],vis[maxn],n,m;

int prim()
{
    memset(d,inf,sizeof(d));
    memset(vis,0,sizeof(vis));
    d[1] = 0;

    int sum = 0;
    while(1)
    {
        int v = -1;
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u] && (v == -1 || d[v] > d[u])) v = u;
        }
        if(v == -1) break;
        vis[v] = 1;
        sum += d[v];
        for(int u = 1;u <= n;u++)
        {
            if(!vis[u]) d[u] = min(d[u],g[v][u]);
        }
    }
    return sum;
}

int main()
{
    while(scanf("%d",&n) != EOF)
    {
        for(int i = 1;i <= n;i++)
        {
            for(int j = 1;j <= n;j++)
            {
                scanf("%d",&g[i][j]);
            }
        }
        scanf("%d",&m);
        for(int i = 1;i <= m;i++)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            g[u][v] = g[v][u] = 0;
        }

        int ans = prim();
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Eric_chen_song_lin/article/details/82748028
今日推荐