Counting Cliques HDU - 5952 (暴力)

版权声明:本文为博主瞎写的,请随便转载 https://blog.csdn.net/sdut_jk17_zhangming/article/details/82657664

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph. 

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6

Sample Output

3
7
15

思路 只枚举这个点所能到达的点(只有20个);

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int a[110][110];
int n,p,len,pp;
int x[11];
int ans;
vector<int> q[110];
void dfs(int xx,int cnt)
{
    if(cnt==len)
    {
        ans++;
        return ;
    }
    int i,j,f;
    for(i=0;i<q[xx].size();i++)
    {
        f = 1;
        int u = q[xx][i];
        for(j=1;j<=cnt;j++)
        {
            if(a[x[j]][u] == 0)
            {
                f = 0;
                break;
            }
        }
        if(f)
        {
            x[cnt+1] = u;
            dfs(u,cnt+1);
        }
    }
}

int main()
{
    int t,m,i,j,u,v;
    scanf("%d",&t);
    while(t--)
    {
        ans = 0;
        scanf("%d%d%d",&n,&m,&len);
        for(i=1;i<=n;i++)
        {
            q[i].clear();
        }
        memset(a,0,sizeof(a));
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            if(u > v) swap(u,v);
            q[u].push_back(v);
            a[v][u] = 1;
            a[u][v] = 1;

        }

        for(i=1;i<=n;i++)
        {
            x[1] = i;
            dfs(i,1);
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdut_jk17_zhangming/article/details/82657664
今日推荐