苏浪浪 201771010120 第三周 Java基本程序设计总结

理论知识:

Java有五种语句:

(1)方法调用语句(2)表达式语句(3)复合语句(4)控制语句(5)package、import语句

3.8控制流程

3.9大数值

*如果基本的整型和浮点型数据无法达到要求的精度,那么可以使用 java.math 包中的两个类,BigInteger和BigDecimal。这两个类可以操作任意长的数字。

*BigInteger类实现了任意精度的整数运算,BigDecimal实现了任意精度的浮点运算。

3.10数组

*数组是一种数据结构,它是有序数据的集合,数组中的每个元素的数据类型都是相同的。

*对元素的确定是由数组名和它的下标实现的,

2、实验部分:

1、实验目的与要求

(1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

(2)熟悉PTA平台线上测试环境;

(3)掌握Java语言构造基本程序语法知识(ch1-ch3);

(4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/,使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

实验2-实验3在课后完成

实验2:公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类的nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

实验3:studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

(1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

(2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

实验结果:

1、

package 小浪浪;
import java.util.Scanner;
public class ll {

    public static void main(String[] args) { 
        Scanner in=new Scanner(System.in);
         System.out.print("card:");
         String ID = in.nextLine();
         int k=0;
         String year=ID.substring(k+6,k+10);
         String mon=ID.substring(k+10,k+12);
         String day=ID.substring(k+12,k+14);
         System.out.println(year+"-"+mon+"-"+day);
    }
}

2、用eclipce创建Javaproject在他下边的包中创建两个类如下图代码(第一个类:student)

package 名单;

public class Student {
    private String name;
    private String studentId;

    public Student(String name, String studentId) {
        this.name = name;
        this.studentId = studentId;
    }

    public String getName() {
        return name;
    }

    public void setName(String name) {
        this.name = name;
    }

    public String getStudentId() {
        return studentId;
    }

    public void setStudentId(String studentId) {
        this.studentId = studentId;
    }

    public Student() {
    }
}

第二类、(Test)

package 名单;
import java.io.BufferedReader;
import java.io.File;
import java.io.FileReader;
import java.io.IOException;
import java.util.ArrayList;
import java.util.Scanner;
public class Test {
    private static ArrayList<Student> studentList = null;
    public static void StudentsFromFile(String fileName){
        File file = new File(fileName);
        BufferedReader reader = null;
        try {
            reader = new BufferedReader(new FileReader(file));
            String tempString = null;
            while ((tempString = reader.readLine()) != null) {
                String str[] = tempString.split(" ");
                if(studentList != null && str.length > 1) {
                    Student student = new Student();
                    student.setStudentId(str[0]);
                    student.setName(str[1]);
                    studentList.add(student);
                }
            }
            reader.close();
        } catch (IOException e) {
            e.printStackTrace();
        } finally {
            if (reader != null) {
                try {
                    reader.close();
                } catch (IOException e1) {
                }
            }
        }
    }


    public static String finStudentIdByName(String name) {
        String studentId = null;
        for(Student student : studentList) {
            if(student.getName().equals(name)) {
                studentId = student.getStudentId();
                break;
            }
        }
        return studentId;
    }
    public static String findStudentNameBId(String ID) {
        String studentName = null;
        for(Student student : studentList) {
            if(student.getStudentId().equals(ID)) {
                studentName = student.getName();
                break;
            }
        }
        return studentName;
    }
    public static void main(String args[]) {
        String path = "D:/名单/studentfile.txt";
        studentList = new ArrayList<Student>();
        StudentsFromFile(path);
        int statu = 1;
        System.out.println();
        while(statu != 0) {
            System.out.println("******************");
            System.out.println("1:Select StudentId By StudentName");
            System.out.println("2:Select StudentName by StudentId");
            System.out.println("0:exit");
            System.out.println("******************");
            Scanner scanner = new Scanner(System.in);
            statu = scanner.nextInt();
            switch(statu) {
                case 1:{
                    System.out.println("Please input student name:");
                    Scanner scanner1 = new Scanner(System.in);
                    String name = scanner1.nextLine();
                    String Id = findStudentIdByName(name);
                    if(Id != null) {
                        System.out.println("Name: "+name+" Id: "+Id);
                    }else {
                        System.out.println("Don`t has this student");
                    }

                }break;
                case 2:{
                    System.out.println("Please input student Id:");
                    Scanner scanner2 = new Scanner(System.in);
                    String Id = scanner2.nextLine();
                    String name = findStudentNameById(Id);
                    if(name != null) {
                        System.out.println("name: "+name+" Id: "+Id);
                    }else {
                        System.out.println("Don`t has this student");
                    }
                }break;
                case 0:
                    statu = 0; break;
                default:
                    System.out.println("input error");
            }
        }
        System.out.println("byebye!");
    }
}

j结果如下图:

本周总结:

在这周理论课学到了本章重点(数组)在周四的实验课中老师组织了一次测验,在这次测验中看到了自己的很多不足,同时也大概对于前三章的重点内容有所了解。也知道复习那些东西;对于本次课后的实验,上边输出生日那个还能自己做出来,第二个在看了别人的代码、通过询问学长以及自己的理解勉强的完成了该实验。对于这个实验我只能表示:我很差,Java的路途很漫长我仍需努力,仍需奋斗。

猜你喜欢

转载自www.cnblogs.com/xiaolangoxiaolang/p/9655991.html