201771010129 王颖奇 第三周 Java基本程序设计总结

 

实验三 Java基本程序设计

实验时间 2018-9-13

201771010129 王颖奇

1、实验目的与要求

1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

2)熟悉PTA平台线上测试环境;

3)掌握Java语言构造基本程序语法知识(ch1-ch3)

4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

成绩:

实验2-实验3在课后完成

实验2公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证的年月日抽取出来,按年-月-日格式输出。注意:输入使用ScannernextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

代码:

package shen;

import java.util.Scanner;

public class shen {

public static void main(String[] args) {

Scanner sc = new Scanner(System.in);

System.out.println("请输入正确的18位身份证号码");

String num = sc.nextLine();

int i = 6;

String year = num.substring(i, i+4);

String yue = num.substring(i+4, i+6);

String ri = num.substring(i+6, i+8);

System.out.println(year+"-"+yue+"-"+ri);

}

}

尾数为数字的身份证号:

尾数为字母的身份证号:

实验3studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:

(1)输入姓名查询学号;

2)输入学号查询姓名。要求程序具有友好人机交互界面。

编程建议:

1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

代码:

package cha;

public class Test {

    private static ArrayList<Student> studentList = null;

    public static void StudentsFromFile(String fileName){

        File file = new File(fileName);

        BufferedReader reader = null;

        try {

            reader = new BufferedReader(new FileReader(file));

            String tempString = null;

            while ((tempString = reader.readLine()) != null) {

                String str[] = tempString.split(" ");

                if(studentList != null && str.length > 1) {

                    Student student = new Student();

                    student.setStudentId(str[0]);

                    student.setName(str[1]);

                    studentList.add(student);

                }

            }

            reader.close();

        } catch (IOException e) {

            e.printStackTrace();

        } finally {

            if (reader != null) {

                try {

                    reader.close();

                } catch (IOException e1) {

                }

            }

        }

    }

    public static String findStudentIdByName(String name) {

        String studentId = null;

        for(Student student : studentList) {

            if(student.getName().equals(name)) {

                studentId = student.getStudentId();

                break;

            }

        }

        return studentId;

    }

    public static String findStudentNameById(String ID) {

        String studentName = null;

        for(Student student : studentList) {

            if(student.getStudentId().equals(ID)) {

                studentName = student.getName();

                break;

            }

        }

        return studentName;

    }

    public static void main(String args[]) {

        String path = "C:\\Users\\ASUS\\Desktop\\java\\实验三\\studentfile.txt";

        studentList = new ArrayList<Student>();

        StudentsFromFile(path);

        int statu = 1;

        System.out.println();

        while(statu != 0) {

            System.out.println("1:Select StudentId By StudentName");

            System.out.println("2:Select StudentName by StudentId");

            System.out.println("0:exit");

            Scanner scanner = new Scanner(System.in);

            statu = scanner.nextInt();

            switch(statu) {

                case 1:{

                    System.out.println("Please input student name:");

                    Scanner scanner1 = new Scanner(System.in);

                    String name = scanner1.nextLine();

                    String Id = findStudentIdByName(name);

                    if(Id != null) {

                        System.out.println("Name: "+name+" Id: "+Id);

                    }else {

                        System.out.println("Don`t has this student");

                    }

                }break;

                case 2:{

                    System.out.println("Please input student Id:");

                    Scanner scanner2 = new Scanner(System.in);

                    String Id = scanner2.nextLine();

                    String name = findStudentNameById(Id);

                    if(name != null) {

                        System.out.println("name: "+name+" Id: "+Id);

                    }else {

                        System.out.println("Don`t has this student");

                    }

                }break;

                case 0:

                    statu = 0; break;

                default:

                    System.out.println("input error");

            }

        }

        System.out.println("byebye!");

    }

}

package cha;

public class Student {

    private String name;

    private String studentId;

    public Student(String name, String studentId) {

        this.name = name;

        this.studentId = studentId;

    }

    public String getName() {

        return name;

    }

    public void setName(String name) {

        this.name = name;

    }

    public String getStudentId() {

        return studentId;

    }

    public void setStudentId(String studentId) {

        this.studentId = studentId;

    }

    public Student() {

    }

}

结果:

总结:

    通过前三章的测试,我了解到了自己在java程序编写方面的不足,需要在课余时间多下功夫学习。另外,通过实验2中,我学会了使用ScannernextLine()方法碰到回车就会结束编写输入字符串的程序;在编写实验3的过程中,我学会了使用student类的方法存放学生数据并编写程序。

猜你喜欢

转载自www.cnblogs.com/1556889081wyq/p/9655891.html