HDU6197 array array array 最长上升子序列 nlgn算法

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tawn0000/article/details/82290227

                                      array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1613    Accepted Submission(s): 798


 

Problem Description

One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?

Input

The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2…An.
1≤T≤20
1≤n≤105
0≤kn
1≤Ai≤105

Output

For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).

Sample Input

 

3 4 1 1 4 3 7 5 2 4 1 3 1 2 6 1 1 4 3 5 4 6

Sample Output

 

A is a magic array. A is a magic array. A is not a magic array.

Source

2017 ACM/ICPC Asia Regional Shenyang Online

nlgn 求最长上升子序列

dp[k] 为长度为k时最小的 a[i]值, 如果a[i] >= dp[j], 说明dp[j+1] = a[i]; 否则 二分查找dp{1-j} 中a[i] 所处的位置,并用a[i]取代。

#include <bits/stdc++.h>

using namespace std;
const int maxn = 1e5 + 100;
int T;
int n,k;
int dp[maxn],a[maxn];

int main()
{
  scanf("%d",&T);
  while(T--)
  {
    scanf("%d%d",&n,&k);
    for(int i = 0; i < n; i++)
      scanf("%d",&a[i]);
    dp[0] = -1;
    int j = 0;
    for(int i = 0; i < n; i++)
      if(a[i] >= dp[j]) dp[++j] = a[i];
      else {
        int idx = lower_bound(dp+1,dp+j+1,a[i]) - dp;
        dp[idx] = a[i];
      }
    if(k >= n-j)  {printf("A is a magic array.\n");continue;}
    dp[0] = -1;j = 0;
    for(int i = 0; i < n/2; i++)  swap(a[i],a[n-1-i]);
    for(int i = 0; i < n; i++)
      if(a[i] >= dp[j]) dp[++j] = a[i];
      else {
        int idx = lower_bound(dp+1,dp+j+1,a[i]) - dp;
        dp[idx] = a[i];
      }
    if(k >= n-j)  {printf("A is a magic array.\n");continue;}
     printf("A is not a magic array.\n");
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/Tawn0000/article/details/82290227
今日推荐