array array array

array array array

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1180    Accepted Submission(s): 605


Problem Description
One day, Kaitou Kiddo had stolen a priceless diamond ring. But detective Conan blocked Kiddo's path to escape from the museum. But Kiddo didn't want to give it back. So, Kiddo asked Conan a question. If Conan could give a right answer, Kiddo would return the ring to the museum.
Kiddo: "I have an array A and a number k, if you can choose exactly k elements from A and erase them, then the remaining array is in non-increasing order or non-decreasing order, we say A is a magic array. Now I want you to tell me whether A is a magic array. " Conan: "emmmmm..." Now, Conan seems to be in trouble, can you help him?
 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with two integers n and k in one line, then one line with n integers: A1,A2An.
1T20
1n105
0kn
1Ai105
 

Output
For each test case, please output "A is a magic array." if it is a magic array. Otherwise, output "A is not a magic array." (without quotes).
 

Sample Input
 
  
34 11 4 3 75 24 1 3 1 26 11 4 3 5 4 6
 
Sample Output
 
  
A is a magic array.A is a magic array.A is not a magic array.
 

Source
 


PS:就是让你求最长不下降子序列长度len,然后判断下n-len是否小于k(将序列反着存下来然后再求即最长不上升子序列,取两者len中的较大值),然后直接套nlogn的模板即可。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<string>
#define LL long long
const int maxn=1e5+5;
using namespace std;
int a[maxn],b[maxn],c[maxn];
int n;
int LIS(int *d)
{
    memset(c,0,sizeof(c));
    c[1]=d[1];
    int l,r,mid,len=1;
    for(int i=2; i<=n; i++)
    {
        l=1;
        r=len;
        while(l<=r)
        {
            mid=(l+r)/2;
            if(c[mid]<=d[i]) l=mid+1;
            else  r=mid-1;
        }
        c[l]=d[i];
        if(l>len) len++;

    }
    return len;
}
int main()
{
    int T;
    scanf("%d",&T);
    int k;
    while(T--)
    {
        scanf("%d%d",&n,&k);
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            b[n-i+1]=a[i];
        }
        int maxn=max(LIS(a),LIS(b));

        if(n-maxn>k)
            printf("A is not a magic array.\n");
        else
            printf("A is a magic array.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40510246/article/details/80009147