zoj-1094Matrix Chain Multiplication(栈来实现矩阵相乘)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/shadowcw/article/details/75671342
Matrix Chain Multiplication

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Matrix multiplication problem is a typical example of dynamical programming.

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500

15125

需要对字符进行处理 如果是'('就跳过 如果是')'就将)前的两个矩阵取出 判断先前的矩阵的行数与后一个的矩阵的列数是否相同 如果不同就输出error 再将乘之后的矩阵继续放回栈中

#include<iostream>
#include<string>
#include<cstring>
#include<stack>
#include<map>
using namespace std;
struct node{int l,r;};
int main()
{
    ios::sync_with_stdio(false);
    map<char,node> m;
    int n;char a;
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        cin>>a;
        cin>>m[a].l>>m[a].r;
    }
    string s;
    while(cin>>s)
    {
        stack<node> u;
        int count=0;
        int i;
        for(i=0;i<s.size();i++)
        {
            if(s[i]=='(')continue;
            else if(s[i]==')')
            {
                node p,q;
                p=u.top();
                u.pop();
                q=u.top();
                u.pop();
                if(p.l!=q.r)
                {
                    cout<<"error"<<endl;
                    break;
                }
                count+=q.l*p.l*p.r;
                node v={q.l,p.r};
                u.push(v);
            }
            else {
                    u.push(m[s[i]]);
            }
        }
        if(i==s.size())
        {
            cout<<count<<endl;
        }
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/shadowcw/article/details/75671342
今日推荐