HDU 6440 Dream(构造)

Dream

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 938    Accepted Submission(s): 150
Special Judge

 

Problem Description

Freshmen frequently make an error in computing the power of a sum of real numbers, which usually origins from an incorrect equation (m+n)p=mp+np, where m,n,p are real numbers. Let's call it ``Beginner's Dream''.

For instance, (1+4)2=52=25, but 12+42=17≠25. Moreover, 9+16−−−−−√=25−−√=5, which does not equal 3+4=7. 

Fortunately, in some cases when p is a prime, the identity

(m+n)p=mp+np


holds true for every pair of non-negative integers m,n which are less than p, with appropriate definitions of addition and multiplication.

You are required to redefine the rules of addition and multiplication so as to make the beginner's dream realized.

Specifically, you need to create your custom addition and multiplication, so that when making calculation with your rules the equation (m+n)p=mp+np is a valid identity for all non-negative integers m,n less than p. Power is defined as

ap={1,ap−1⋅a,p=0p>0



Obviously there exists an extremely simple solution that makes all operation just produce zero. So an extra constraint should be satisfied that there exists an integer q(0<q<p) to make the set {qk|0<k<p,k∈Z} equal to {k|0<k<p,k∈Z}. What's more, the set of non-negative integers less than p ought to be closed under the operation of your definitions.

Hint


Hint for sample input and output:
From the table we get 0+1=1, and thus (0+1)2=12=1⋅1=1. On the other hand, 02=0⋅0=0, 12=1⋅1=1, 02+12=0+1=1.
They are the same.

 

Input

The first line of the input contains an positive integer T(T≤30) indicating the number of test cases.

For every case, there is only one line contains an integer p(p<210), described in the problem description above. p is guranteed to be a prime.

 

Output

For each test case, you should print 2p lines of p integers.

The j-th(1≤j≤p) integer of i-th(1≤i≤p) line denotes the value of (i−1)+(j−1). The j-th(1≤j≤p) integer of (p+i)-th(1≤i≤p) line denotes the value of (i−1)⋅(j−1).

 

Sample Input

 

1 2

 

Sample Output

 

0 1 1 0 0 0 0 1

题意:给你一个质数p,你要重新定义0~p-1的每两个数的加法和乘法结果,使等式

(a+b)^k==a^k+b^k 成立(任意 0< = a,b,k < p)

同时由于全0肯定是成立的,所以再加一个条件:存在一个q(0<=q<p),使得q的k次方(k=0,1,...,p-1)的结果正好是0,1,...,p-1的一个排列。

题解是这样构造的:

由于p是质数,由费马小定理,定义a+b=(a+b)%p,a*b=(a*b)%p,则一定有(a+b)^k==a^k+b^k。(因为答案都mod p了,而p是质数)

我觉得这样构造是对的没错,但其实还有其他的方法。比赛的时候我们想的是这种方法:

定义

0*1=0

k*1=k+1(k=1,2,...,p-2)

(p-1)*1=1

其他的全为0。这样的话就满足题目中所给的条件了。

代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
#define qq cout<<"1";
#define pp cout<<"0";
using namespace std;
const int maxn=200010;
const ll mo=1e9+7;
int n,m,p;
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>p;
        for(int i=0;i<p;i++)
        {
        for(int j=0;j<p;j++)
        {
          if(j) cout<<" ";
          pp
        }
        cout<<endl;
        }
        for(int i=0;i<p;i++)
        {for(int j=0;j<p;j++)
        {
          if(j) cout<<" ";
          //if(i==1&&j!=p-1&&j>0) cout<<i+j;//这两行加不加都能过,因为只需要有一个i满足条件就行了。
          //else if(i==1&&j==p-1&&j>0) qq
         if(j==1&&i!=p-1&&i>0) cout<<i+j;
          else if(j==1&&i==p-1&&i>0) qq
          else pp
        }
        cout<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/LSD20164388/article/details/82079905
今日推荐