HDU 5122 : K.Bro Sorting(冒泡排序升级版)

                                            K.Bro Sorting

Description

Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, … , N .

Input

The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 10 6).

The second line contains N integers a i (1 ≤ a i ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 10 6.

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.

Sample Input



5 4 3 2 1 

5 1 2 3 4

Sample Output

Case #1: 4 
Case #2: 1

Hint

In the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.

题意:

我们来看这一道题,他是说输入n个整数,然后然后随机抽取一个数字进行冒泡排序,问你最少随机抽几个就是一个递增序列。

思路:

其实类似于冒泡排序,不过这道题的思维性非常强,如果没有练过这个类型的题目,可能真的不会做。

方法就是先设最后一个数为最小值,然后往前递减,如果前面的那个数大于最小值的话,就次数加1,如果小于等于最小值的话,那个数就变成了最小值。

代码:

#include<bits/stdc++.h>
using namespace std;
int t;//表示测试用例的数量
int n;//表示数组里面有多少个数字 
int a[100001];//用来存放数字
int main()
{
	scanf("%d",&t);
	for(int i=0;i<t;i++)
	{
		memset(a,0,sizeof(a));//数组初始化 
		int ans=0;//用来统计数字一共要移动几次,特别要注意的就是这一个地方,ans一定要清零; 
		scanf("%d",&n);
		for(int j=0;j<n;j++)
		{
			scanf("%d",&a[j]);
		}
		int minx=a[n-1];//先让数组最后一个为最小值 
		for(int k=n-2;k>=0;k--)
		{
			if(a[k]>minx)//如果前面的比最小值小的话,那么ans就要加一了; 
			{
				ans++;
			}
			else//如果前面的比最小值要大的话,那么最小值就是前面的那一个数 
			{
				minx=min(a[k],minx);
			}
		}
		printf("Case #%d: %d\n",i+1,ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/rnzhiw/article/details/81707139
今日推荐