HDU 5122 K.Bro Sorting (贪心)。。误以为是树状数组。。。

K.Bro Sorting

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 4369    Accepted Submission(s): 1886


 

Problem Description

Matt’s friend K.Bro is an ACMer.

Yesterday, K.Bro learnt an algorithm: Bubble sort. Bubble sort will compare each pair of adjacent items and swap them if they are in the wrong order. The process repeats until no swap is needed.

Today, K.Bro comes up with a new algorithm and names it K.Bro Sorting.

There are many rounds in K.Bro Sorting. For each round, K.Bro chooses a number, and keeps swapping it with its next number while the next number is less than it. For example, if the sequence is “1 4 3 2 5”, and K.Bro chooses “4”, he will get “1 3 2 4 5” after this round. K.Bro Sorting is similar to Bubble sort, but it’s a randomized algorithm because K.Bro will choose a random number at the beginning of each round. K.Bro wants to know that, for a given sequence, how many rounds are needed to sort this sequence in the best situation. In other words, you should answer the minimal number of rounds needed to sort the sequence into ascending order. To simplify the problem, K.Bro promises that the sequence is a permutation of 1, 2, . . . , N .

 

Input

The first line contains only one integer T (T ≤ 200), which indicates the number of test cases. For each test case, the first line contains an integer N (1 ≤ N ≤ 106).

The second line contains N integers ai (1 ≤ ai ≤ N ), denoting the sequence K.Bro gives you.

The sum of N in all test cases would not exceed 3 × 106.

 

Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of rounds needed to sort the sequence.

 

Sample Input

 

2 5 5 4 3 2 1 5 5 1 2 3 4

 

Sample Output

 

Case #1: 4 Case #2: 1

Hint

In the second sample, we choose “5” so that after the first round, sequence becomes “1 2 3 4 5”, and the algorithm completes.

 

Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6331 6330 6329 6328 6327 

 

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<set>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1e9+7
#define ll long long
#define maxn 1000005
#define MAX 1000000000
#define ms memset
using namespace std;

int n,seq[maxn];
/*
题目大意:题目中给定了一个排序手段,
每次选定一个数往右移动直至遇到一个比它大的数或到头了为止。
计算选数排序的最小次数。

刚开始仔细想了很久没想出来,
后来偶然间发现其实就是个贪心。
考虑后缀,假设后缀已经全部排好序,
那么这时候遇到第一个数(从后往前),
如果是比最小的还小,无所谓,不影响,
如果大(破坏了有序性)则对该数进行一次移动,
根据性质一定是维护了后缀的有序性。

那么有没有更好的方法用更少的次数呢?
本人暂时证明不出来。。。只是有点感觉
如果谁能证明出来务必留言讨论
*/

int main()
{
    int t;scanf("%d",&t);
    for(int ca=1;ca<=t;ca++)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&seq[i]);
        int cnt=0;
        for(int i=n-2;i>=0;i--)
        {
            if(seq[i]>seq[i+1])
            {
                cnt++;
                swap(seq[i],seq[i+1]);
            }
        }
        printf("Case #%d: %d\n",ca,cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37451344/article/details/81326128
今日推荐