PAT甲级--1114 Family Property(25 分)【并查集】

1114 Family Property(25 分)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

解题思路:这题用了并查集,了解并查集可以看看https://blog.csdn.net/Imagirl1/article/details/82353349,了解这里用2个结构,一个存储答案,一个用来处理输入数据,并查集就是来找有多少个家族,然后统计每个家族有多少人多少sets多少area,然后注意下输出来就好了,这里-1的人不要处理。

#include<bits/stdc++.h>
using namespace std;
struct Data{//处理输入数据
	int id,fid,mid;
	int c[6];
	int num,area;
};
struct Ans{//答案的元素
	int id,people;
	double num,area;
	bool flag;//flag是最终的父亲节点为true,多少个true,多少个家庭
};
Ans ans[10000];
Data data[10000];

bool cmp(Ans a,Ans b)//答案输出的顺序
{
	if(a.area!=b.area) return a.area>b.area;
	else return a.id<b.id;
}
int father[10000];
bool visit[10000];//判断是不是活着的

//并查集
int find(int x)
{
	while(x!=father[x])
	x=father[x];
	return x;
}

void union1(int x,int y)
{
	int fa1=find(x);
	int fa2=find(y);
	if(fa1>fa2) father[fa1]=fa2;
	else if(fa1<fa2) father[fa2]=fa1;
}

int main(void)
{
	int n,k;
	scanf("%d",&n);
	for(int i=0;i<10000;i++)
	father[i]=i;
	for(int i=0;i<n;i++)
	{
		scanf("%d %d %d %d",&data[i].id,&data[i].fid,&data[i].mid,&k);
		visit[data[i].id]=true;
		if(data[i].fid!=-1)//只处理还在的人
		{
			visit[data[i].fid]=true;
			union1(data[i].fid,data[i].id);
		}
		if(data[i].mid!=-1)//只处理在的人
		{
			visit[data[i].mid]=true;
			union1(data[i].mid,data[i].id);
		}
		for(int j=0;j<k;j++)
		{
			scanf("%d",&data[i].c[j]);
			visit[data[i].c[j]]=true;
			union1(data[i].c[j],data[i].id);
		}
		scanf("%d %d",&data[i].num,&data[i].area);
	}
	for(int i = 0; i < n; i++) {
        int id = find(data[i].id);//找出最父亲的节点,把data[i]的所有东西都加到这个节点
        ans[id].id = id;
        ans[id].num += data[i].num;
        ans[id].area += data[i].area;
        ans[id].flag = true;
    }
	int cnt=0;
	for(int i=0;i<10000;i++)
	{
		if(visit[i])//还在的人
		{
			ans[find(i)].people++;//最父亲的节点的人数加1
		}
		if(ans[i].flag==true) cnt++;//多少个true多少个家族
	}
	for(int i=0;i<10000;i++)
	{
		if(ans[i].flag)
		{
			ans[i].num=(double)(ans[i].num*1.0/ans[i].people);
			ans[i].area=(double)(ans[i].area*1.0/ans[i].people);
		}
	}
       sort(ans, ans + 10000, cmp);
       printf("%d\n", cnt);
       for(int i = 0; i < cnt; i++)
       printf("%04d %d %.3f %.3f\n", ans[i].id, ans[i].people, ans[i].num, ans[i].area);
       return 0;
}

猜你喜欢

转载自blog.csdn.net/Imagirl1/article/details/82384316