PAT 1114 Family Property 并查集

This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child1 … Childk M_estate Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0<=k<=5) is the number of children of this person; Childi’s are the ID’s of his/her children; M_estate is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG_sets AVG_area

where ID is the smallest ID in the family; M is the total number of family members; AVG_sets is the average number of sets of their real estate; and AVG_area is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.

Sample Input:
10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:
3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

题意就是按照题目要求把一个人的信息给我们 让我们根据给出的信息网络
找出一个家庭中符合条件的信息输出 这个家庭的最小编号 家庭人数 每个人的人均数量和人均房产面积

并查集和搜索 都可以做 这里我用了并查集
每个结构体里多记录点信息 然后合并的时候好合并 因为这些信息都是可以加减替代更新到根节点上的 这里我们可以把输入的所有有关联的id全部连接起来
然后连接的时候如果不是在一个联通块中就要把不同联通块更新到一个联通块中
最后输出的时候 就是把每个家庭的根节点排序输出出来即可

#include<bits/stdc++.h>
using namespace std;
struct node{
    int f,s_area,s_set,min_id,pep;  
}n[10003];
void unin(int a,int b){
    n[b].f = a;
    n[a].min_id = min(n[a].min_id,n[b].min_id);
    n[a].pep +=n[b].pep;
    n[a].s_area+=n[b].s_area;
    n[a].s_set+=n[b].s_set;
}
bool cmp(node a,node b){
    return ((double)a.s_area/a.pep)>((double)b.s_area/b.pep)||
    (((double)a.s_area/a.pep)==((double)b.s_area/b.pep)&&a.min_id<b.min_id);
}// 
int find(int x){
    int k,p,j=x;
    while(n[x].f!=x)x = n[x].f;
    k = x;
    while(n[j].f!=j){
        p = n[j].f;
        n[j].f = k;
        j = p;      
    }
    return k;
}
int main()
{
    int N;
    scanf("%d",&N);
    for(int i=0;i<=9999;i++){
        n[i].f=i;
        n[i].min_id = i;
        n[i].pep = 1;
    }
    set<int>pep;
    while(N--){
        int id,fa,ma,k;
        scanf("%d%d%d%d",&id,&fa,&ma,&k);
        pep.insert(id);
        int fid = find(id);
        if(fa!=-1){
            int ffa = find(fa);
            if(ffa!=fid)unin(fid,ffa);  //      
            pep.insert(fa);
        }
        if(ma!=-1){
            int fma = find(ma);
            if(fma!=fid)unin(fid,fma);      //
            pep.insert(ma);
        }
        while(k--){
            int child;
            scanf("%d",&child);
            int fchild = find(child);//
            if(fchild!=fid)unin(fid,fchild);//
            pep.insert(child);
        }
        int m_es,area;
        scanf("%d%d",&m_es,&area);
        n[fid].s_area+=area;
        n[fid].s_set+=m_es;
    } 
    set<int>s;// 去重复根节点 
    vector<node>ans; 
    for(set<int>::iterator i = pep.begin();i!=pep.end();i++){
        int c = find(*i);
        if(s.find(c)==s.end()){
            s.insert(c);
            ans.push_back(n[c]);
        }
    }
    sort(ans.begin(),ans.end(),cmp);
    printf("%d\n",ans.size());
    for(int i = 0;i<ans.size();i++){
        printf("%04d %d %.3f %.3f\n",ans[i].min_id,ans[i].pep,(double)ans[i].s_set/ans[i].pep,(double)ans[i].s_area/ans[i].pep);
    }//
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_33859479/article/details/79574530