Silver Cow Party POJ - 3268(dij)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  Ai, Bi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

        题意:农场里有很多牛棚,一个牛棚一头牛,在x牛棚举行聚会,这些牛都要去参加,但t它们只想走最短的路,给你一些单向的路线,求所有出来回最短路线中最长的

        方法:从x处开始走用dij,然后反向边再次dij

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<vector>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int inf=0x3f3f3f3f;
const int mod=1e9+7;
const int N=2000000+10;
int n,m,x;
int maps[1005][1005],dist1[1005],dist2[1005],vis[1005];
void dij(int dist[])
{
    memset(vis,0,sizeof(vis));
    memset(dist,inf,sizeof(dist));
    for(int i=1;i<=n;i++)
        dist[i]=maps[x][i];
    vis[x]=1;
    for(int k=1;k<n;k++)
    {
        int mins=inf,mark=0;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&mins>dist[i])
            {
                mins=dist[i];
                mark=i;
            }
        }
        vis[mark]=1;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&dist[i]>dist[mark]+maps[mark][i])
            {
                dist[i]=dist[mark]+maps[mark][i];
            }
        }
    }
}
int main()
{
    scanf("%d%d%d",&n,&m,&x);
    memset(maps,inf,sizeof(maps));
    for(int i=0;i<m;i++)
    {
        int u,v,w;
        scanf("%d%d%d",&u,&v,&w);
        maps[u][v]=w;
    }
    dij(dist1);
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        swap(maps[i][j],maps[j][i]);
    dij(dist2);
    int sum=0;
    for(int i=1;i<=n;i++)
        if(i!=x)
            sum=max(sum,dist1[i]+dist2[i]);
    printf("%d\n",sum);
}



发布了10 篇原创文章 · 获赞 1 · 访问量 357

猜你喜欢

转载自blog.csdn.net/hl_1997/article/details/80031823