POJ——3169Layout

POJ——3169Layout

Layout
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14702   Accepted: 7071

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

 
 

题目大意:

n头牛编号为1到n,按照编号的顺序排成一列,每两头牛的之间的距离 >= 0。这些牛的距离存在着一些约束关系:

1.有ml组(u, v, w)的约束关系,表示牛[u]和牛[v]之间的距离必须 <= w。

2.有md组(u, v, w)的约束关系,表示牛[u]和牛[v]之间的距离必须 >= w。

问如果这n头无法排成队伍,则输出-1,如果牛[1]和牛[n]的距离可以无限远,则输出-2,否则则输出牛[1]和牛[n]之间的最大距离。

 

差分约束入门题

首先记$d[i]$为第$i$头奶牛到第1头奶牛的距离,由于奶牛们按顺序排列,$d[i]<=d[i+1]$

第一种约束:$d[u]-d[v]<=w$,可作如下转化$d[u]<=d[v]+w$

观察发现这个式子很像求解最短路时spfa的松弛操作,的确与他有关,建立的模型便是$差分约束系统$

 
#pragma GCC optimize(2)
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
#include<cmath>

#define inf 0x7fffffff
#define N 100010
using namespace std;

int n,ml,md,head[N],tot;
struct node{
    int to,next,w;
}e[N];

void add(int u,int v,int w){
    e[++tot].to=v,e[tot].next=head[u],head[u]=tot,e[tot].w=w;
}

int d[N],in[N];
bool vis[N];
queue<int>Q;
int spfa(){
    memset(vis,0,sizeof(vis));
    fill(d+1,d+1+n,inf);
    d[1]=0;Q.push(1);vis[1]=1;
    while(!Q.empty()){
        int u=Q.front();Q.pop();vis[u]=0;
        for(int i=head[u];i;i=e[i].next){
            int v=e[i].to;
            if(d[v]>d[u]+e[i].w){
                d[v]=d[u]+e[i].w;
                if(!vis[v]){
                    vis[v]=1;
                    in[v]++;
                    if(in[v]>n) return -1;
                    Q.push(v);
                }
            }
        }
    }
    if(d[n]==inf) return-2;
    else return d[n];
}

int main()
{
    scanf("%d%d%d",&n,&ml,&md);
    for(int u,v,w,i=1;i<=ml;i++){
        scanf("%d%d%d",&u,&v,&w);
        if(v>u) swap(v,u);
        add(v,u,w);
    }
    for(int u,v,w,i=1;i<=md;i++){
        scanf("%d%d%d",&u,&v,&w);
        if(u<v) swap(u,v);
        add(u,v,-w);
    }
    for(int i=1;i<n;i++) add(i+1,i,0);
    printf("%d",spfa());
    return 0;
}
 
借鉴博客 yew1eb  AndyZhang  Dust_Heart

猜你喜欢

转载自www.cnblogs.com/song-/p/9579651.html