hdu 1561 The more, The Better【树形dp】

Problem Description

ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?

Input

每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。

Output

对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。

Sample Input

 

3 2 0 1 0 2 0 3 7 4 2 2 0 1 0 4 2 1 7 1 7 6 2 2 0 0

Sample Output

5 13

分析:

比较基础,跟https://blog.csdn.net/lml11111/article/details/81986542类似

代码:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
#define MAXN 200+10
using namespace std;
int dp[MAXN][MAXN];///dp[i][j] 表示以i节点为根的树 选中j个点
vector<int> G[MAXN];
int N, M;
void DFS(int u)
{
    for(int i = 0; i < G[u].size(); i++)
    {
        int v = G[u][i];
        DFS(v);
        for(int j = M+1; j >= 1; j--)///必须从大到小,否则会影响后续的值
        {
            for(int k = 1; k < j; k++)
                dp[u][j] = max(dp[u][j], dp[u][j-k] + dp[v][k]);
        }
    }
}
int main()
{
    while(~scanf("%d%d", &N, &M)&&(N||M))
    {
        for(int i = 0; i <= N; i++)
            G[i].clear();
        memset(dp, 0, sizeof(dp));
        int a, b;
        for(int i = 1; i <= N; i++)
        {
            scanf("%d%d", &a, &b);
            G[a].push_back(i);
            dp[i][1] = b;   ///以i节点为根的树只选了 i 一个点
        }
        DFS(0);
        printf("%d\n", dp[0][M+1]);     ///以0节点为根的树选M+1个点的最优解 里面有0节点
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lml11111/article/details/81988338
今日推荐