POJ-1426

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题意:输出一个比n大且只有0和1组成的数
思路:因为只有10
11
加0
所以深搜11和10加0加1遍历所有情况

#include<cstdio>
using namespace std;
int n,f;
void dfs(long long m,int step)
{
    if(f||step>18) return;
    if(m%n==0)
    {
        printf("%lld\n",m);
        f=1;
    }
    dfs(m*10,step+1);
    dfs(m*10+1,step+1);
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)  break;
        f=0;
        dfs(1,0);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_42964711/article/details/81938661