Be the Winner(博弈+SJ定理应用)

Problem Description
Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is 
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).
 

Input
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.
 

Output
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".
 

Sample Input
 
  
22 213
 

Sample Output
 
  
No

Yes

直接引用SJ定理:

#include <stdio.h>
#include <iostream>
#include <cstring>
using namespace std;
int main()
{
	int t ,n , sg[1000];
	while(~scanf("%d" , &t))
	{
		int res = 0 , flag = 0;
		for(int i = 0 ; i < t ; i++)
		{
			scanf("%d" , &sg[i]);
			if(sg[i] > 1)
			{
				flag = 1;
			}
		}
		for(int i = 0 ; i < t ; i++)
		{
			res ^= sg[i];
		}
		if(res != 0 && flag == 1)
		{
			printf("Yes\n");
		}
		else if(res == 0 && flag == 0)
		{
			printf("Yes\n");
		}
		else
		{
			printf("No\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41593380/article/details/80043247