Image Transformation

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

The image stored on a computer can be represented as a matrix of pixels. In the RGB (Red-Green-Blue) color system, a pixel can be described as a triplex integer numbers. That is, the color of a pixel is in the format "r g b" where r, g and b are integers ranging from 0 to 255(inclusive) which represent the Red, Green and Blue level of that pixel.

Sometimes however, we may need a gray picture instead of a colorful one. One of the simplest way to transform a RGB picture into gray: for each pixel, we set the Red, Green and Blue level to a same value which is usually the average of the Red, Green and Blue level of that pixel (that is (r + g + b)/3, here we assume that the sum of r, g and b is always dividable by 3).

You decide to write a program to test the effectiveness of this method.

Input

The input contains multiple test cases!

Each test case begins with two integer numbers N and M (1 <= NM <= 100) meaning the height and width of the picture, then three N * M matrices follow; respectively represent the Red, Green and Blue level of each pixel.

A line with N = 0 and M = 0 signals the end of the input, which should not be proceed.

Output

For each test case, output "Case #:" first. "#" is the number of the case, which starts from 1. Then output a matrix of N * M integers which describe the gray levels of the pixels in the resultant grayed picture. There should be N lines with M integers separated by a comma.

Sample Input

2 2
1 4
6 9
2 5
7 10
3 6
8 11
2 3
0 1 2
3 4 2
0 1 2
3 4 3
0 1 2
3 4 4
0 0

Sample Output

Case 1:
2,5
7,10
Case 2:
0,1,2
3,4,3

题解:输入n和m,分别输入三次n*m的矩阵,输出每个矩阵对应位置的平均数,注意格式。

代码:

#include<iostream>
#include<stdio.h>
using namespace std;
int r[105][105];
int g[105][105];
int b[105][105];
int ans[105][105];
int main()
{
    int n,m;
    int k=1;
    while(cin>>n>>m&&n&&m)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>r[i][j];
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>g[i][j];
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                cin>>b[i][j];
        cout<<"Case "<<k<<":"<<endl;
        k++;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                ans[i][j]=(r[i][j]+g[i][j]+b[i][j])/3;
            }
        }
        for(int i=0;i<n;i++)
        {
            cout<<ans[i][0];
            for(int j=1;j<m;j++)
            {
                cout<<","<<ans[i][j];
            }
            cout<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42671353/article/details/81876993