HDU 1162(prime算法)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11971    Accepted Submission(s): 6009


 

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

 

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.

 

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 

 

Sample Input

 

3 1.0 1.0 2.0 2.0 2.0 4.0

 

Sample Output

 

3.41

PS:其实就是一个最小生成树的问题,就是让所有点都连接,并且路径最小,用prime算法就可以了。

AC代码:

#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<string>
#include<map>
#include<cmath>
#include<vector>
const int maxn=1e2+5;
const int mod=1e9+7;
const int inf=1e9;
#define me(a,b) memset(a,b,sizeof(a))
typedef long long ll;
using namespace std;
double maps[maxn][maxn],sum;
int n;bool vis[maxn];
struct node
{
    double x,y;
}a[maxn];
double prime()
{
    double d[maxn];
    fill(d,d+maxn,inf);d[1]=0;
    me(vis,0);
    for(int i=1;i<=n;i++)
    {
        int u=-1;double ma=inf;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&d[j]<ma)
                ma=d[j],u=j;
        if(u==-1)
            return -1;
        vis[u]=1,sum+=ma;
        for(int j=1;j<=n;j++)
            if(!vis[j]&&maps[u][j]<d[j])
                d[j]=maps[u][j];
    }
    return sum;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&a[i].x,&a[i].y);
        fill(maps[0],maps[0]+maxn*maxn,inf),sum=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                int x=a[i].x-a[j].x,y=a[i].y-a[j].y;
                maps[i][j]=sqrt(x*x+y*y);
            }
        printf("%.2f\n",prime());
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41292370/article/details/81449605
今日推荐