hdu4135 Co-prime

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6933    Accepted Submission(s): 2733


 

Problem Description

Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

 

Input

The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 1015) and (1 <=N <= 109).

 

Output

For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

 

Sample Input

 

2 1 10 2 3 15 5

扫描二维码关注公众号,回复: 2503660 查看本文章
 

Sample Output

 
Case #1: 5 Case #2: 10

Hint

In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

代码:

#include<cstdio>
#include<algorithm>
#include<map>
#define ll long long
using namespace std;
map<ll,ll> mp;
ll a[2000];    
int pos; 
void solve(ll n)
{
    pos = 0;
    for (ll i = 2;i * i <= n;i ++)
    {
        if (n % i == 0)
        {
            while (n % i == 0)
            {
                a[pos] = i;
                n /= i;
            }
            pos ++;
        }
    }
    if (n != 1) a[pos ++] = n;
}
ll exc(ll n,ll m)
{
    ll ans = 0;
    for (int i = 1;i < (1 << m);i ++)
    {
        int cnt = 0,lm = 1;
        for (int j = 0;j < m;j ++)
        {
            if ((i >> j) & 1)
            {
                cnt += 1;
                lm *= a[j];
            }
        }
        if (cnt & 1) ans += n / lm;
        else ans -= n / lm;
    }
    return ans;
}
int main()
{
    int t,kase = 0;
    scanf("%d",&t);
    while (t--)
    {
        kase ++;
        ll n,a,b;
        scanf("%lld %lld %lld",&a,&b,&n);
        solve(n);
        ll numb = exc(b,pos);
        ll numa = exc(a - 1,pos);
        printf("Case #%d: %lld\n",kase,b - a + 1 - (numb - numa));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/cloudy_happy/article/details/81212692
今日推荐