HDU-1016-Prime Ring Problem(dfs)

Prime Ring Problem


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
解题思路:
先确定1的位置,然后从2开始搜,实现相邻两个数的和是素数

程序代码:

#include<stdio.h>
int num[21],book[21],n;
int is_prime[22]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0};
int dfs(int pre,int post,int flag)
{
    int i;
    if(is_prime[pre+post]==0)
    	return 0;
    num[flag]=post;
    if(flag==n&&is_prime[post+1])
    {
        for(i=1;i<n;i++)
    		printf("%d ",num[i]);
    	printf("%d\n",num[n]);
        return 1;
    }
    book[post]=1;	
    for(i=2;i<=n;i++)
    	if(book[i]==0&&dfs(post,i,flag+1)==1)
			break;
    book[post]=0;
    return 0;
}
int main()
{
    int count=1,i;
    while(scanf("%d",&n)!=EOF)
    {
		for(i=1;i<=n;i++)
        	book[i]=0;
        num[1]=1;
        printf("Case %d:\n",count++);
        if(n==1)
			printf("1\n");
        for(i=2;i<=n;i++)
        	dfs(1,i,2);
        printf("\n");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81056350
今日推荐