hdu 1973 Prime Path

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.

1033
1733
3733
3739
3779
8779
8179

The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

题意如下:

就是给出两个素数a,b, 每次操作只允许将a中的一个数字变换,问最少经过多少次才能将a变换成b。

当时一看到最短,

首先想到的是bfs, 然后发现可以将4位素数存储起来, 用于搜索。 。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#include <cmath>
using namespace std;
int n;
int a,b;
int is_pr[10005];
int snum=0;
int vis[10005];
struct card
{
    int data;
    int num;
};
int bfs()
{
    if(a==b)
        return 0;
    vis[a]=1;
    queue<card>q;
    card now,next;
    now.data=a; now.num=0;
    q.push(now);
    while (!q.empty())
    {
        now=q.front();
        q.pop();
        for (int i=0;i<snum;i++)
        {
            int ci=0;
            if(!vis[is_pr[i]])
            {
                next.data=is_pr[i];
                next.num=now.num+1;
                int ttemp1=next.data;
                int ttemp2=now.data;
                for (int j=0;j<4;j++)
              {
                int aa=ttemp1%10;
                int bb=ttemp2%10;
                ttemp1/=10;
                ttemp2/=10;
                if(aa==bb)
                {
                    ci++;
                }
              }
            if(ci==3)
             {
                //printf("%d %d %d\n",is_pr[i],now.data,now.num);
                if(next.data==b)
                    return next.num;
                q.push(next);
                vis[next.data]=1;
             }
            }

        }


    }

}
int isPrime(int n)
{
    if(n<=1)
        return 0;
    if(n==2||n==3)
        return 1;
    if(n%6!=5&&n%6!=1)
        return 0;
    for(int i=5;i<=sqrt(n);i++)
        if(n%i==0||n%(i+2)==0)
        return 0;
    return 1;
}
int main()
{
    scanf("%d",&n);
    for (int i=1000;i<=9999;i++)
    {
          if(isPrime(i))
          {
              is_pr[snum++]=i;
              //printf("%d\n",is_pr[snum-1]);
          }
    }
    while (n--)
    {
        scanf("%d%d",&a,&b);
         memset (vis,0,sizeof(vis));
        printf("%d\n",bfs());

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81347869
今日推荐