【CSU1554】SG Value(优先队列)

题目链接

1554: SG Value

Submit Page    Summary    Time Limit: 5 Sec     Memory Limit: 256 Mb     Submitted: 484     Solved: 162    


Description

The SG value of a set (multiset) is the minimum positive integer that could not be constituted of the number in this set.
You will be start with an empty set, now there are two opertions:
1. insert a number x into the set;
2. query the SG value of current set.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1e5) -- the total number of opertions.
The next N lines contain one opertion each.
1 x means insert a namber x into the set;
2 means query the SG value of current set.

Output

For each query output the SG value of current set.

Sample Input

5
2
1 1
2
1 1
2

Sample Output

1
2
3

Hint

Source

解题思路:

设当前的 SG value 为ans,插入的值为x。

1.如果x>ans, 那么now的值不会改变。把这个数放进集合中(简单模拟一下就能知道了);

2.如果x<=ans, 那么ans += x, 由于此次ans的增大,在集合中小于等于ans的数,还能够使ans继续增大。使得ans增大之后,这个数应该从集合中删去。

然后用优先队列维护这个集合即可。

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;
priority_queue<LL, vector<LL>, greater<LL> >q;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        LL ans=1;
        while(!q.empty())
            q.pop();
        while(n--)
        {
            LL t,x;
            scanf("%lld",&t);
            if(t==1)
            {
                scanf("%lld",&x);
                if(x>ans)
                {
                    q.push(x);
                    continue;
                }
                ans+=x;
                while(!q.empty() && q.top()<=ans)
                {
                    ans+=q.top();
                    q.pop();
                }
            }
            if(t==2)
                printf("%lld\n",ans);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39826163/article/details/81808515