(HDU5547)Sudoku-DFS

                                                Sudoku

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 3312    Accepted Submission(s): 1100


 

Problem Description

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board with every row contains 1 to 4, every column contains 1 to 4. Also he made sure that if we cut the board into four 2×2 pieces, every piece contains 1 to 4.

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

 

Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test cases follow. Each test case starts with an empty line followed by 4 lines. Each line consist of 4 characters. Each character represents the number in the corresponding cell (one of '1', '2', '3', '4'). '*' represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.

 

Output

For each test case, output one line containing Case #x:, where x is the test case number (starting from 1). Then output 4 lines with 4 characters each. indicate the recovered board.

 

Sample Input

 

3

****

2341

4123

3214

*243

*312

*421

*134

*41*

**3*

2*41

4*2*

Sample Output

 

Case #1:

1432

2341

4123

3214

Case #2:

1243

4312

3421

2134

Case #3:

3412

1234

2341

4123

题意分析:

题目大意在*号处放数,使得该列该行该块内的数为1234。很简单,对与每个*枚举他可能的数,看该列该行该块是否可以凑成1234四个数就可以了。

代码:

#include<iostream>
#include<vector>
using namespace std;

struct Node {
	int x;
	int y;
	Node(int x1, int y1) { x = x1; y = y1; }
};

int N;
char mapp[5][5];
vector<Node> temp;		//存每个*的坐标的
int visit[5][5];		//visit[i][j]表示第i行的第j个数是否存在!!!
int visit1[5][5];		//visit1[i][j]表示第i列的第j个数是否已存在!!!
int visit2[5][5];		//visit2[i][j]表示第i块的第j个数是否已经存在!!!

void DFS(int h) {
	if (h == temp.size()) {			//打印结果
		for (int i = 0; i < 4; i++) {
			for (int j = 0; j < 4; j++) {
				cout << mapp[i][j];
			}
			cout << endl;
		}
		return;
	}
	for (int i = 1; i <= 4; i++) {
		if (!visit[temp[h].x][i] && !visit1[temp[h].y][i] && !visit2[temp[h].x / 2 * 2 + temp[h].y / 2][i])	//如果该行该列该块的数不存在就往下搜下一个*号
		{
			visit[temp[h].x][i] = 1;
			visit1[temp[h].y][i] = 1;
			visit2[temp[h].x / 2 * 2 + temp[h].y / 2][i] = 1;
			mapp[temp[h].x][temp[h].y] = i + '0';
			DFS(h + 1);
			mapp[temp[h].x][temp[h].y] = '*';
			visit[temp[h].x][i] =0;
			visit1[temp[h].y][i] = 0;
			visit2[temp[h].x / 2 * 2 + temp[h].y / 2][i] = 0;
		}
	}
}

int main() {
	cin >> N;
	int i = 0;
	while (N--) {
		temp.clear();
		memset(visit, 0, sizeof(visit));
		memset(visit1, 0, sizeof(visit1));
		memset(visit2, 0, sizeof(visit2));

		for (int i = 0; i < 4; i++) {
			for (int j = 0; j < 4; j++) {
				cin >> mapp[i][j];
				if(mapp[i][j]=='*')
				temp.push_back(Node(i,j));
				else {
					visit[i][mapp[i][j]-'0'] = 1;
					visit1[j][mapp[i][j]-'0'] = 1;
					visit2[i/2*2+j/2][mapp[i][j]-'0'] = 1;	//注意这里判断*属于第几块的计算方法 i,j均是从0开始记数故可以用i/2*2+j/2来表示第几块,不懂的可以画图计算一下。
				}
			}
		}
		cout << "Case #" << ++i << ":" << endl;
		DFS(0);
	}
	return 0;
}

 

猜你喜欢

转载自blog.csdn.net/xiaosi1524/article/details/81428599