POJ 2676 Sudoku 【dfs】

Sudoku

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 27881 Accepted: 12773 Special Judge

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107
Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127

思路:
从左上角开始试着填数,这个数应该是该行、该列和方块中都未出现的数字,如果出现过就return false, 没有出现过就进行下一次的搜索。
注意vis的表示方法
在这里插入图片描述
代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<fstream>
#include<ctime>        

using namespace std;
int res[10][10];
bool row[10][10];
bool col[10][10];
bool grid[10][10];
bool dfs(int r, int c){
	if(r == 9)return true;
	bool flag = false;
	if(res[r][c]){
		if(c == 8)//这一行已经查找完了, 进行下一行的查找
		flag = dfs(r + 1, 0);
		else flag = dfs(r, c + 1);// 这一行没有查找完, 就进行这一行的下一列的查找
		return flag;
	}
	int k = (r / 3 ) * 3 + c / 3;
	for(int i = 1; i <= 9; i++){//注意 这里是1--9 代表可以填的9个数字
		if(!row[r][i]&&!col[c][i]&&!grid[k][i]){//判断这个数字可以填
			row[r][i] = col[c][i] = grid[k][i] = true;
			res[r][c] = i;
			if(c == 8){
				
				flag = dfs(r + 1, 0);
			}
				else {
					flag = dfs(r, c + 1);
				}
				if(flag)///代表下一个位置可以填 不然就在这个位置继续查找下一个数字
					return true;
			row[r][i] = col[c][i] = grid[k][i] = false;//回溯
				res[r][c] = 0;
			
			
		}
	}
	return false;//在这个位置找完了都没有可以填的, 就回溯到上一个位置
}

int main()
{
	int t;
	cin >> t;
	while(t--){
		memset(row, false, sizeof(row));
		memset(col, false, sizeof(col));
		memset(grid, false, sizeof(grid));
		for(int i = 0; i < 9; i++)
			for(int j = 0; j < 9; j++){
				char temp;
				cin >> temp;
				res[i][j] = temp - 48;
				if(res[i][j]){
					row[i][res[i][j]] = true;
					col[j][res[i][j]] = true;
					int k = (i/3)*3 + j/3; //*****
					grid[k][res[i][j]] = true;
				}
			}
			dfs(0,0);
			for(int i = 0; i < 9; i++){
				for(int j = 0; j < 9; j++){
					cout << res[i][j];
				}
				cout << endl;
			}
	}

    return 0;
}

发布了28 篇原创文章 · 获赞 22 · 访问量 1043

猜你喜欢

转载自blog.csdn.net/qq_45432665/article/details/103207822