HDU3466背包买东西

Problem Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

Input

There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.

Output

For each test case, output one integer, indicating maximum value iSea could get.

Sample Input

2 10

10 15 10

5 10 5

3 10

5 10 5

3 5 6

2 7 3

Sample Output

5

11

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3466

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=50005;
int dp[N];
const int T=505;
typedef struct st{
int p,q,v;
}St;
bool cmp(St a, St b)
{
    return a.q-a.p<b.q-b.p;
}
int main()
{
    int n,m;
    St a[T];
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
        }
        memset(dp,0,sizeof(dp));
        sort(a,a+n,cmp);
        for(int i=0;i<n;i++)
        {
            for(int j=m;j>=a[i].q;j--)
            {
                dp[j]=max(dp[j],dp[j-a[i].p]+a[i].v);/*这里考验理解背包的精髓,
背包的j是依次往下递减的,不能出现先减后增,决定了排序方式*/
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/81517209
今日推荐