【2016 CCPC 网络赛 】K Lweb and String

Lweb and String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1838    Accepted Submission(s): 863


 

Problem Description

Lweb has a string S.

Oneday, he decided to transform this string to a new sequence. 

You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing). 

You need transform every letter in this string to a new number.

A is the set of letters of S, B is the set of natural numbers. 

Every injection f:A→B can be treat as an legal transformation. 

For example, a String “aabc”, A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3. 

Now help Lweb, find the longest LIS which you can obtain from S.

LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)

Input

The first line of the input contains the only integer T,(1≤T≤20).

Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105.

Output

For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.

Sample Input

2

aabcc

acdeaa

Sample Output

Case #1: 3

Case #2: 4

Author

UESTC

Source

2016中国大学生程序设计竞赛 - 网络选拔赛

问题链接:HDU5842 Lweb and String

题目大意:给你一个均由小写字母组成的字符串,你可以重新定义每个字母的相对大小,问各种定义下严格的最长递增子序列的最大值

题解:由于可以自定义各个字母的最大值,因此实际上答案就是不同字母的个数,具体看代码

AC的C++程序:

#include<iostream>
#include<cstring>
#include<string>

using namespace std;

int main()
{
	int t,a[26];
	scanf("%d",&t);
	for(int i=1;i<=t;i++)
	{
		string s;
		cin>>s;
		memset(a,0,sizeof(a));
		for(int j=0;j<s.length();j++)
		  a[s[j]-'a']=1;
		int ans=0;
		for(int j=0;j<26;j++)
		  ans+=a[j];
		printf("Case #%d: %d\n",i,ans);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/81738257
今日推荐