HDU 4046 Panda 线段树

When I wrote down this letter, you may have been on the airplane to U.S.
We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror. I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn't know how many Saerdna's love there are in the letter.
Can you help Panda?

Input

An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.
The next m lines
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R<n)
Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)

Output

For each test case, output the case number first.
The answer of the question.

Sample Input

2

5 2
bwbwb
0 0 4
0 1 3
5 5
wbwbw
0 0 4
0 0 2
0 2 4
1 2 b
0 0 4

Sample Output

Case 1: 
1 
1 
Case 2: 
2 
1 
1 
0

题意:

3个连续的wbw算是一个love。看一下某个区间共同拥有多少个love,多次询问。

还有替换某个位置的字母,然后询问。

思路:

可以通过对读入的字符串三个三个的判定,然后通过判定结果来建立线段树。

然后当查询的时候, 对修改的那个字母所影响的字符串进行重新更新。

线段树存的是区间字符串的个数。

代码如下:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=50005;
//线段树
int tree[maxn<<2];
int t;
int n,m;
char s[maxn];
void pushup (int re)
{
  tree[re]=tree[re<<1]+tree[re<<1|1];
}
void build (int l,int r,int re)
{
    tree[re]=0;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build (l,mid,re<<1);
    build (mid+1,r,re<<1|1);
}
//节点更新
void update (int l,int r,int re,int loc,int data)
{
    if(l==r)
    {
        tree[re]=data;
        return;
    }
    int mid=(l+r)>>1;
    if(loc<=mid)
        update (l,mid,re<<1,loc,data);
    else
        update (mid+1,r,re<<1|1,loc,data);
    pushup (re);
}
//区间查询
int query (int l,int r,int re,int left,int right)
{
    if(l>=left&&r<=right)
    {
        return tree[re];
    }
    int ans=0;
    int mid=(l+r)>>1;
    if(mid>=left)
        ans+=query (l,mid,re<<1,left,right);
    if(mid<right)
        ans+=query (mid+1,r,re<<1|1,left,right);
    return ans;
}
int main()
{
    scanf("%d",&t);
    for (int j=1;j<=t;j++)
    {
        scanf("%d%d",&n,&m);
        scanf("%s",s);
        build (1,n,1);
        for (int i=0;i<=n-2;i++)
        {
            //判定是否为love,若是,则更新节点
             if(!strncmp(s+i,"wbw",3))
                  update (1,n,1,i+1,1);
        }
        printf("Case %d:\n",j);
        for (int i=0;i<m;i++)
        {

            int q,x,y;
            char yy;
            scanf("%d",&q);
            if(q)
            {
                scanf("%d %c",&x,&yy);
                s[x]=yy;
                //判定一个字符改变是否影响三个字符串
                for (int k=-2;k<=0;k++)
                {
                    if(x+k>=0&&x+k<n)
                    {
                        if(!strncmp(s+x+k,"wbw",3))
                            update (1,n,1,x+k+1,1);
                        else
                            update (1,n,1,x+k+1,0);
                    }
                }
            }
            else
            {
                scanf("%d%d",&x,&y);
               if(y-x<2)
                 printf("0\n");
               else
               {
                   //输出有几个符合条件的字符串
                   printf("%d\n",query(1,n,1,x+1,y-1));
               }
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81749392